ModuleNotFoundError: 'aquacrop.solution_aot'

Hi all,
I just installed the aquacrop ospy package - in a conda environment running python 3.7
The only other packages in this environment are: numpy, pandas, scipy, matplotlib and notebook
I tried to import the aquacrop package into a new notebook, here is my code:
from aquacrop.classes import *
from aquacrop.core import *
however, I am getting this error: “ModuleNotFoundError: No module named ‘aquacrop.solution_aot’”
is this an issue with the python version?
thank you,
chinedum

Hi @celuwa

Can I just check how you installed the latest version. Either from the GitHub source or pip install aquacrop ?

If you installed from source then you need to now run python -m aquacrop.solution after installation.

There is more info in the release notes but we are now compiling the code at installation instead of at import time.

I should have updated the the readme so will do that asap

Tom

hi @tom thank you for your reply. I think I installed it from pip install aquacrop.
do i still need to run this python -m aquacrop.solution after the pip install?

hey @tom … i think this fix works.
thank you so much.
Chinedum.

Good to here it worked. I’m still working on a permanent solution as it should be automatically running that line of code as the user installs but under certain circumstances it dosent.